Developer Portal Community

    Showing results for 
    Search instead for 
    Did you mean: 

    Can't download deploy HMI

    Can't download deploy HMI

    Established Member

    Hi comunity,

     I can't download an HMI to an IPC. Everytime that i try it i get the same error:


    The IPC is configured as TARGET_MODE=HMI

    Versions: CPS5.1.0 - IPC 5.1 - HMI 5.1.1

    What can be wrong?


    Thasnks in advance

    3 REPLIES 3

    Long-established Member

    You have to install certificate to target system.

    After your unsuccessful connection you should find created certificate in C:\NexeedLocal\Certificates\RAT.Server\pkiserver\rejected. If I remember correctly the name of file should contain Bosch name of your computer. Move this file to C:\NexeedLocal\Certificates\RAT.Server\pkiserver\trusted\certs and try to deploy the IPC again. It should work.

    Whole procedure is described in OES help. Look into section Project Creation > Target Systems > Activating the Control plus Studio certificate on the target system.

    Community Moderator
    Community Moderator

    Actually the error message from the original post has a different reason:

    The target system image had probably just been applied from the service stick. The RAT service on the PLC creates its own certificate when it is started the first time. This certificate has a period of validity which starts at the time where it is created.

    The realtime clock of some PLCs (e.g. C6017) tends to run a little fast. I.e., at the time it is created, the certificate is not yet valid when evaluated on a computer where the system time is not ahead.

    And that's the error message you got: The development computer (client) does not accept the certificate from the PLC (server) because it is not yet valid. So actually, this problem was solved by waiting for some minutes, not by the steps in the accepted answer.

    Nevertheless, the hint in the accepted answer is correct: When deploying to the target system for the first time, you need to trust the client certificate on the server side. Otherwise you also get an error message, though it would be this one:

    RAT client: Secure connect failed. Make sure the client certificate is in the servers "trust" list.

    maj9bj describes correctly how the certificate can be trusted manually on the file level. Alternatively, you can use the SecurityManager app on the target system which is accessible through the tray icon looking like a shield.

    Long-established Member

    Additional information on this issue. Yesterday I solved the same problem with a colleague and the cause was incorrect validity of the OWN certificate. The problem was caused by the wrong date being set on the mPad. 2031 instead of 2023. This then affected the validity of the certificate. The solution was to set the correct date and time and delete the incorrect certificate.