Developer Portal Community

    cancel
    Showing results for 
    Search instead for 
    Did you mean: 
    SOLVED

    Can't download deploy HMI

    Despejo47
    New Poster

    Can't download deploy HMI

    Hi comunity,

     I can't download an HMI to an IPC. Everytime that i try it i get the same error:

    Despejo47_0-1624269007406.png

    The IPC is configured as TARGET_MODE=HMI

    Versions: CPS5.1.0 - IPC 5.1 - HMI 5.1.1

    What can be wrong?

     

    Thasnks in advance

    2 REPLIES 2
    maj9bj
    Member

    Re: Can't download deploy HMI

    You have to install certificate to target system.

    After your unsuccessful connection you should find created certificate in C:\NexeedLocal\Certificates\RAT.Server\pkiserver\rejected. If I remember correctly the name of file should contain Bosch name of your computer. Move this file to C:\NexeedLocal\Certificates\RAT.Server\pkiserver\trusted\certs and try to deploy the IPC again. It should work.

    Whole procedure is described in OES help. Look into section Project Creation > Target Systems > Activating the Control plus Studio certificate on the target system.

    nexidator
    Community Moderator

    Re: Can't download deploy HMI

    Actually the error message from the original post has a different reason:

    The target system image had probably just been applied from the service stick. The RAT service on the PLC creates its own certificate when it is started the first time. This certificate has a period of validity which starts at the time where it is created.

    The realtime clock of some PLCs (e.g. C6017) tends to run a little fast. I.e., at the time it is created, the certificate is not yet valid when evaluated on a computer where the system time is not ahead.

    And that's the error message you got: The development computer (client) does not accept the certificate from the PLC (server) because it is not yet valid. So actually, this problem was solved by waiting for some minutes, not by the steps in the accepted answer.

    Nevertheless, the hint in the accepted answer is correct: When deploying to the target system for the first time, you need to trust the client certificate on the server side. Otherwise you also get an error message, though it would be this one:

    RAT client: Secure connect failed. Make sure the client certificate is in the servers "trust" list.

    maj9bj describes correctly how the certificate can be trusted manually on the file level. Alternatively, you can use the SecurityManager app on the target system which is accessible through the tray icon looking like a shield.

    Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist