Developer Portal Community

    cancel
    Showing results for 
    Search instead for 
    Did you mean: 

    Ccs object

    joaomrq
    New Poster

    Re: Ccs object

    Hello,

    That would explain the behaviour, but the dummy command is not active.

    Thank you.

    Düscha
    Member

    Re: Ccs object

    Increment from the eventId only work if the CCS send a eventId.

    This is not a indicator that the plc and the ccs communicate.

    Have you checked the setting from my replay with the exported method?

    Have you checked that the communication is running?

    Peripherals-->Instancer of your Peripheral-->_connectionState or better _socket.ConState.

    _socket is the directly TCP connection.

    Have you checked that TCP/IP license is activate on your PLC?

     

    joaomrq
    New Poster

    Re: Ccs object

    Hello,

    You are correct, I cannot verify wihtout a doubt if the communication is being established between Nexeed PLC and the test sequencer.

    I checked the ReturnCodeError method and it's being exported and we have a set event enabled when the OutCmd.ReturnCode <> 0.

    We checked that the peripheral is connected (the ConState is true, at least).

    The only clue that no communication is being made is that the EventId is not incrementing although the command is endind succesfully.

     

    The problem is that this behaviour is very dificult to replicate. I'm trying on my laptop and I couldn't still find what causes this.

    Another detail is that all the variables inside ResultDef are not changed, remaining as they were from the last succesfull command.

     

    We haven't checked on any low level TCP sockets status on Windows. If I can replicate the behaviour I will check that.

     

    Thank you.

    Düscha
    Member

    Re: Ccs object

    You are sure that the CCS/UTS site working correct?

    Have you communication telegrams (PLC to CCS and CCS to PLC) that you can send us

    joaomrq
    New Poster

    Re: Ccs object

    Hi,

     

    That's one problem. We can't be sure that UTS is working correcly.

    We are discussing with UTS team trying to debug on their side as well.

     

    So far, I wasn't able to crash the system on my laptop, even with several instances.

    I don't have the telegrams now, but I will do some more texts next week and I'll post here the results as well as sample telegrams.

     

    Thank you.

    Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist