Developer Portal Community

    cancel
    Showing results for 
    Search instead for 
    Did you mean: 
    SOLVED

    XDK error message module 0

    VMehta
    New Poster

    XDK error message module 0

    I am new to the XDK workbench environment. Trying to connect it via mqtt to a mosquitto broker. It successfully connects to the wifi but spits out the following error

    Error in XDK110 Application package.
    INFO | XDK DEVICE 1: Package ID: 153
    INFO | XDK DEVICE 1: Module ID: 0
    INFO | XDK DEVICE 1: Severity code: 2
    INFO | XDK DEVICE 1: Error code: 12

    I tried looking for the module but did not find any with the ID 0.

    After the above error, MQTT_Connect failed to connect and tries reconnecting again with the same result.

    Any help will be much appreciated 

     

    Tags (2)
    2 REPLIES 2
    LlobetAtWork
    Long-established Member

    Re: XDK error message module 0

    Hello VMehta,

    Module 0 is very uncommon as a module ID and could mean a custom module.
    Error code 12 is a semaphore error. In the Serval (non AWS) MQTT module this appears when handling MQTT events from the stack (HandleServalMQTTEvents) and may come with an uninitialized signal. I suppose that the setup phase of the MQTT agent was not called, hence no signal is available when the connection gets a stack callback.

    Best regards,

    Francisco Llobet

     

     

     

    VMehta
    New Poster

    Re: XDK error message module 0

    I am using eclipse Mita and not the sample program given in the Workbench. As far as I have gathered from the documentation, the setup phase of MQTT includes transport, the broker url, the clientID and the topics. Am I missing something?

    Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist