Developer Portal Community

    Showing results for 
    Search instead for 
    Did you mean: 

    Application Firmware Corrupted

    New Poster

    Application Firmware Corrupted

    Hey there,

    I recently bought a XDK device. Today I wanted to smoothly dive into the world of MITA.

    However when I tried to get a simple HelloWorld-Application running I faced some challenges.

    It started well and the application was working as expected. Then something strange happened. The application started to write "Hello World" twice when pressing the button. I thought it is a buffer error or something else. I also experienced a lot of issues while flashing the device. Very often the following appeared in the console:

    INFO | Booting application...
    INFO | XDK DEVICE 1: Performing application CRC validation (this will take a couple of seconds)
    INFO | XDK DEVICE 1: Application Firmware Corrupted
    INFO | XDK DEVICE 1: Invalid application

    If I tried to flash it again or sometimes just reboot the device - then the application worked fine again.

    But now the situation got worse. I am always retrieving the abovementioned error.

    I searched on the internet for solutions. I tried to set "Add XDK Nature" (whatever this is), but it did not work.

    I've also tried to perform a reset (holding button one when turning on the device), but it did not work.


    Any idea what this could be?




    4 REPLIES 4
    Occasional Contributor

    Re: Application Firmware Corrupted

    Hello Sucuk,

    The Reason for this issue is Header portion was missing in the binary file. So during Application CRC Validation, it was getting failed. Thats why you are getting below error message,

    INFO | XDK DEVICE 2: Application Firmware Corrupted
    INFO | XDK DEVICE 2: Invalid application

    When you compile the application, if header portion is generated then you must get below message,

    INFO | Creating Firmware Over the Air (FOTA) Container

    INFO | Binary File: C:\Users\mvs5cob\XDK-Workspace\XdkApplicationTemplate\debug\XdkApplicationTemplate.bin
    INFO | Header Version: 0100
    INFO | Product Class: 0010
    INFO | Product Variant: 0000
    INFO | Firmware Version: 00000000

    Once after getting this message, if you flash the application. Application will work.


    Re: Application Firmware Corrupted

    Hello Mahalingam,

    I tried the hello-world program and get the same error. 

    If the reason for this issue is the missing header portion in the binary file, could you please guide me on how to resolve this?

    Thanks in advance,


    Occasional Contributor

    Re: Application Firmware Corrupted

    Hello Chandan,

    If you try to Re-Flash the application it will work.

    The Problem is when you are trying to compilation and flash the application. Somehow header portion was not added in binary file. So when you flash the application. It throw an error as "Invalid Application"

    If Header is properly generated in binary file, You will get below message in the XDK Workbench console,



    Re: Application Firmware Corrupted

    Hello Mahalingam,

    Re-Flashing the application worked as you suggested.

    Thank you